New minimum macOS version#

The macosx backend now requires macOS >= 10.12.