pyparsing>=2.3.1 is now required#