Increase to minimum supported versions of Python and dependencies

For Matplotlib 3.6, the minimum supported versions are being bumped:

Dependency

min in mpl3.5

min in mpl3.6

NumPy

1.17

1.19

This is consistent with our Minimum version of dependencies policy and NEP29